Geomorphic Change Detection Software

Checking for DotNet

Windows 7 users won’t need to worry about this. However, Windows XP users might need to read below.

Any users attempting to install GCD 5 on a machine with Windows XP Pro, need to ensure that before ArcGIS is installed, DotNet Version 3.5 or later is installed (see here to install DotNet 4.0). If .Net Framework Version 3.5 or later is not installed first, ArcGIS will not install the .NET components necessary to run the GCD 5 tools. See herefor more information. Windows 7 users do not need to worry about this because .Net comes pre-installed.

If you are unsure whether or not you have .NET installed, see this video:

If you know you have .NET installed, but are not sure if ArcGIS was installed after or before this, you may need to follow these instructions.

What is DotNet anyway?

Similar to how many applications and software coded in Java, require you to have the Java runtime installed on your machine, programs coded using Microsoft’s Visual Basic or C# languages require you to have .NET installed to run. All .NET is:

  • Common Language Runtime – provides an abstraction layer over the operating system
  • Base Class Libraries – pre-built code for common low-level programming tasks
  • Development frameworks and technologies – reusable, customizable solutions for larger programming tasks

For more information on .NET see http://www.microsoft.com/net/.